资源与论文
数据处理、实验设计与可复现计算
C02- 查看原文
NIST/SEMATECH e-Handbook of Statistical Methods
提供数据探索、测量过程、实验设计、过程建模、统计检验、置信区间和多过程比较的可操作参考。
教材 · National Institute of Standards and Technology
计算机组成
C03- 查看原文
1 Basics of Information: Computation Structures
位序列、信息编码和数值表示的课程讲义与练习。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
4 Combinational Logic: Computation Structures
布尔函数、组合电路与逻辑设计练习。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
5 Sequential Logic: Computation Structures
寄存器、同步状态与时序约束的课程材料。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
9 Designing an Instruction Set: Computation Structures
Beta 处理器的指令集设计和寻址方式。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
7 Performance Measures: Computation Structures
延迟、吞吐率和流水计算的度量。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
15 Pipelining the Beta: Computation Structures
流水阶段、指令相关性和暂停的课程材料。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
14 Caches and the Memory Hierarchy: Computation Structures
缓存组织、映射和存储访问分析。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
- 查看原文
18 Devices and Interrupts: Computation Structures
设备寄存器、输入输出和中断机制。
课程 · Massachusetts Institute of Technology · 2017
- 查看原文
RV32I Base Integer Instruction Set, Version 2.1
RV32I 整数寄存器、算术运算、装载存储和控制转移规范。
教材 · RISC-V International
操作系统
C04- 查看原文
MIT 6.1810: Operating System Engineering
围绕 xv6 学习系统调用、页表、线程与文件系统,配有编程实验。
课程 · Massachusetts Institute of Technology · 2025
- 查看原文
Operating Systems: Three Easy Pieces
操作系统教材,按进程、并发、内存和持久存储提供免费章节、代码与练习。
教材 · Arpaci-Dusseau Books · 2023
- 查看原文
xv6: a simple, Unix-like teaching operating system
MIT 的 RISC-V xv6 教材,讲解系统调用、页表、锁、调度与文件系统实现。
教材 · Massachusetts Institute of Technology · 2025
- 查看原文
计算机网络
C05- 查看原文
CS 144: Introduction to Computer Networking
斯坦福大学计算机网络课程,包含字节流、TCP 收发端、路由与网络测量实验。
课程 · Stanford University · 2026
- 查看原文
- 查看原文
RFC 826: An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet Hardware
说明以太网上网络层地址与链路地址之间的查询报文和缓存处理。
论文与标准 · RFC Editor · 1982
- 查看原文
RFC 894: A Standard for the Transmission of IP Datagrams over Ethernet Networks
规定 IPv4 数据报在以太网中的类型字段、载荷和填充方式。
论文与标准 · RFC Editor · 1984
- 查看原文
RFC 4632: Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation Plan
说明无类别地址前缀、地址分配和路由聚合规则。
论文与标准 · RFC Editor · 2006
- 查看原文
RFC 8200: Internet Protocol, Version 6 (IPv6) Specification
定义 IPv6 基础首部、扩展首部、逐跳限制和源端分片。
论文与标准 · RFC Editor · 2017
- 查看原文
- 查看原文
RFC 9293: Transmission Control Protocol (TCP)
汇总 TCP 字节流、序号、确认、窗口和连接状态的基础规范。
论文与标准 · RFC Editor · 2022
- 查看原文